Setting Bandwidth Mikrotik

Dalam jaringan QoS memegang peranan utama dalam memberikan layanan terhadap client. Untuk mencapai layanan tersebut perlu adanya pembatasan terhadap peket data yang akan diberikan agar seluruh client yang terhubung dalam sebuah network dapat terhubung dengan baik dalam memnafaatkan jaringan internet. Dalam hal ini MikrotikOS menyertakan paket software untuk management bandwidth.
Untuk management bandwidth terdapat konfigurasi trafik shaping dengan metode Simple Queue, sesuai namanya settingan ini sangat sederhana dan memiliki kelemahan dan memberikan hasil tidak real pada monitoring bandwidth dan pada kasus-kasus tertentu terjadi pada koneksi jaringan dengan client di atas 20.
Pada settingan kali ini diasumsikan client sebanyak 15 dan masing-masing client akan diberi jatah bandwidth minimum sebesar 8kbps dan maksimum 48kbps, sementara bandwidth total sebesar 192kbps. untuk upload tidak diberi batasan yang artinya masing-masing client dapat menggunakan bandwidth upload secara maksimum.
Berikut contoh konfigurasi berdasarkan kasus yang dibahas :
/ queue simple add name="trafikshaping" target-addresses=192.168.0.0/27 dst-address=0.0.0.0/0 interface=all parent=none priority=1 queue=default/default limit-at=0/64000 max-limit=0/192000 total-queue=default disabled=no add name="01" target-addresses=192.168.0.1/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="02" target-addresses=192.168.0.2/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="03" target-addresses=192.168.0.3/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="04" target-addresses=192.168.0.4/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="10" target-addresses=192.168.0.25/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="05" target-addresses=192.168.0.5/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="06" target-addresses=192.168.0.6/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="07" target-addresses=192.168.0.7/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="08" target-addresses=192.168.0.8/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="09" target-addresses=192.168.0.9/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="10" target-addresses=192.168.0.10/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="11" target-addresses=192.168.0.11/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="12" target-addresses=192.168.0.12/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="13" target-addresses=192.168.0.13/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="14" target-addresses=192.168.0.14/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no add name="15" target-addresses=192.168.0.15/32 dst-address=0.0.0.0/0 interface=all parent=trafikshaping priority=1 queue=default/default limit-at=0/8000 max-limit=0/48000 total-queue=default disabled=no

Pilihan lain metode bandwidth manajemen ini, kalau seandainya ingin bandwidth tersebut dibagi sama rata oleh Mikrotik, seperti bandwidth 256kbps downstream dan 256kbps upstream. Sedangkan client yang akan mengakses sebanyak 10 client, maka otomatis masing-masing client mendapat jatah bandwidth upstream dan downstream sebanyak 256kbps dibagi 10. Jadi masing-masing dapat 25,6kbps. Andaikata hanya 2 Client yang mengakses maka masing-masing dapat 128kbps.

Untuk itu dipakai type PCQ (Per Connection Queue), yang bisa secara otomatis membagi trafik per client. Sebelumnya dibuat terlebih dahulu pada bagian Mangle sebagai berikut :

/ip firewall mangle add chain=forward src-address=192.168.0.0/27 action=mark-connection new-connection-mark=users-con /ip firewall mangle add connection-mark=users-con action=mark-packet new-packet-mark=users chain=forward

Karena type PCQ belum ada, maka perlu ditambah, ada 2 type PCQ ini. Pertama diberi nama pcq-download, yang akan mengatur semua trafik melalui alamat tujuan/destination address. Trafik ini melewati interface Local. Sehingga semua traffik download/downstream yang datang dari jaringan 192.168.0.0/27 akan dibagi secara otomatis. Tipe PCQ kedua, dinamakan pcq-upload, untuk mengatur semua trafik upstream yang berasal dari alamat asal/source address. Trafik ini melewati interface public. Sehingga semua traffik upload/upstream yang berasal dari jaringan 192.168.0.0/27 akan dibagi secara otomatis. Berikut perintahnya :

/queue type add name=pcq-download kind=pcq pcq-classifier=dst-address /queue type add name=pcq-upload kind=pcq pcq-classifier=src-address

Setelah aturan untuk PCQ dan Mangle ditambahkan, sekarang untuk aturan pembagian trafiknya. Queue yang dipakai adalah Queue Tree, Yaitu:

/queue tree add parent=Local queue=pcq-download packet-mark=users /queue tree add parent=Public queue=pcq-upload packet-mark=users

Perintah diatas mengasumsikan, kalau bandwidth yang diterima dari provider Internet berflukstuasi atau berubah-rubah. Jika kita yakin bahwa bandwidth yang diterima, misalkan dapat 256kbs downstream, dan 256kbps upstream, maka ada lagi aturannya.

Untuk trafik downstreamnya :

/queue tree add name=Download parent=Local max-limit=256k /queue tree add parent=Download queue=pcq-download packet-mark=users

Dan trafik upstreamnya :

/queue tree add name=Upload parent=Public max-limit=256k /queue tree add parent=Upload queue=pcq-upload packet-mark=users

Sampai disini kita dapat memanfaatkan fasilitas management bandwidth pada MikrotikOS, dan dapat membagi serta membatasi client agar client lain dapat memanfaatkan jaringan

Disponsori Oleh :

Semoga Artikel Setting Bandwidth Mikrotik Bisa Bermanfaat untuk kita semua.